Une mise à jour vers Windows 8.1 rock’n’roll qui en fait baver!

Hier matin, j’ai commis la stupide erreur de tenter une mise à jour vers Windows 8.1 sur l’ultrabook de Nuance. J’avais des problèmes avec Windows Update qui n’arrivait pas à aller chercher les mises à jour. Après un mois, le système commençait à se plaindre qu’il ne pouvait trouver de mises à jour et m’invitait à intervenir. Le seul contournement que j’ai trouvé consistait à accéder à l’application Windows Update pour ensuite cliquer sur Check online for updates. Le problème, c’est que la configuration téléchargée par Nuance pour les mises à jour ne fonctionnait pas.

J’ai envoyé une requête au support technique de Nuance et reçu, après quelques temps, une réponse m’offrant deux moyens de résoudre le problème. La première solution consistait à retirer l’ultrabook du domaine, effectuer les mises à jour, puis remettre la machine dans le domaine. Je ne savais pas du tout comment procéder pour faire cela et me doutais bien qu’il me faudrait un mot de passe administrateur pour remettre la machine dans le domaine!

La deuxième solution: mettre à niveau vers Windows 8.1. J’avais déjà effectué l’opération avec succès sur mon ordinateur personnel. Il n’y avait eu que de petits problèmes mineurs. L’opération était gratuite… en théorie. Elle m’a par contre coûté beaucoup de temps et beaucoup de stress…

Windows Store qui bogue

Alors hier matin, je travaillais chez moi et j’ai démarré la mise à jour en tâche de fond. Pour cela, je suis allé sur le Windows Store et cherché, cherché, cherché: pas de référence à Windows 8.1! Bon, l’installation de Windows 8 n’est pas compatible. Une petite recherche sur Google plus tard, j’ai appris que je pouvais démarrer la commande wsreset pour réinitialiser la cache de Windows Store. Je l’ai fait et voilà que Windows 8.1 est apparu! J’ai amorcé son téléchargement et son installation.

Quelques temps plus tard, le système m’a balancé un message me demandant de redémarrer la machine. J’ai reporté le redémarrage, voulant attendre le meeting de 10h30 pendant lequel je n’aurais pas besoin de l’ultrabook qui pourrait alors effectuer la mise à jour. Le message est revenu une dizaine de minutes plus tard puis, vers 10h, la machine a redémarré en sauvage, laissant tout mon travail en plan! Je n’étais pas très content, car j’avais encore des difficultés avec une fonctionnalité supposée en place depuis des mois! En fait, je m’étais simplement trompé dans le nom d’un paramètre; il n’y avait pas de régression à déplorer.

La mise à jour s’est bien passée, mais ça a été un peu long. Par contre, après, le système a souffert de plusieurs séquelles qui ne sont pas encore toutes guéries.

Plus de VPN

D’abord, la connexion au VPN ne fonctionnait plus du tout. Si je démarrais l’utilitaire de Cisco pour établir le lien, le programme m’indiquait qu’il devait être réinstallé. J’ai été choqué de constater que je ne disposais sur l’ultrabook d’aucune copie du programme d’installation! Sans le VPN, je n’avais pas accès au serveur Git pour le partage du code source, au serveur JIRA pour la gestion des bogues, au serveur SharePoint pour la gestion de documents et au pipeline NLU nécessaire au test de l’application! J’étais à peu près bloqué! Je pouvais par chance accéder à Lync pour la messagerie instantanée, Outlook pour les courriers électroniques et The Voice (plateforme fondée sur Jive) pour l’échange d’informations.

J’ai alors tenté d’allumer mon ordinateur sous Ubuntu et de là, établir une liaison VPN. J’ai dû installer le plugin VPNC qui manquait, pour permettre à NetworkManager d’établir la liaison avec un VPN de Cisco. J’ai indiqué à NetworkManager le nom du serveur VPN, mon nom d’utilisateur, le nom du groupe et son mot de passe, puis j’ai fait une tentative. Le système m’a demandé mon mot de passe que j’aientré.

Soit dit en passant, obtenir le mot de passe du groupe n’est pas simple. Il m’a fallu, voilà quatre ans, l’extraire du profil VPN utilisé par le client sous Windows. Un utilitaire que j’ai oublié m’a permis de le décrypter, ensuite de quoi je pouvais l’entrer sous Ubuntu.

Cette manœuvre a fonctionné à quelques reprises par le passé, mais pas ce matin-là. J’avais beau tout essayer: rien n’y faisait. Ça sentait le bogue, car tous mes paramètres étaient corrects. Choqué, je me suis juré de planifier le remplacement de Ubuntu, devenu instable et imprévisible, par quelque chose d’autre comme Fedora. C’est seulement hier soir que j’ai trouvé qu’il fallait entrer Nuance comme domaine dans les options avancées pour que ça fonctionne enfin!

Par chance, je disposais d’une copie de l’utilitaire VPN sur mon ordinateur personnel, je ne sais pas exactement pourquoi! Cela m’a sauvé, car sans cela, j’aurais été obligé de partir de chez moi en catastrophe pour me rendre au bureau.

Juste transférer l’utilitaire a posé des difficultés. La liaison SMB ne fonctionnait pas, encore une fois, et je n’avais ni le temps ni le goût de figurer pourquoi. Je ne pouvais donc pas me brancher sur ma machine en utilisant \\drake. De toute façon, un autre ordinateur chez Nuance possède le nom de Drake, ce qui m’empêche d’atteindre ma machine personnelle par son nom. Je me refuse à renommer une machine; c’est un peu comme une entité qui a été baptisée. J’aurais peut-être pu réussir à l’atteindre avec \\192.168.1.60, mais je n’y ai pas pensé. En effet, je lui ai donnée une IP statique en l’associant à mon adresse MAC au niveau de mon routeur.

Puisque SMB ne fonctionnait pas, je me suis rabattu sur sftp. Ben non! Il n’est pas disponible depuis Git Bash; il m’aurait fallu installer toute la grosse patente de bastringue de Cygwin pour pouvoir l’avoir. Bon, à bien y penser, j’aurais pu réussir avec FileZilla, mais en fin de compte, c’est scp qui est venu à bout du travail, de peine et de misère, car il m’a fallu trouver le chemin exact du fichier et le copier/coller.

Bon, la chose faite, j’ai démarré l’utilitaire qui s’est plaint encore: il fallait désinstaller le client existant. Je l’ai fait, j’ai réinstallé, mais pour je ne sais pas quelle raison, Windows 8.1 a perdu la possibilité de se brancher à Internet. Je ne pouvais plus accéder à quoi que ce soit! Même une recherche sur Google échouait. La machine, maintenant coupée de tout, serait complètement inutilisable pour travailler. Si je ne trouvais pas une solution, il ne me restait plus qu’à partir pour le bureau ou me monter en catastrophe un setup de travail sur le Drake… ah bien non, le VPN ne fonctionnait plus sous Ubuntu! Il m’aurait fallu installer ça sous Windows 8, alors. Mais peut-être le client VPN sous Windows 8.1 allait sur ma machine aussi faire sauter l’accès à Internet!

Avant de céder à la panique, j’ai tenté un redémarrage: en vain. J’ai tenté d’établir un branchement wi-fi, me disant que la carte réseau USB avait peut-être rendu l’âme. Je pouvais certes établir la liaison, mais le système n’arrivait pas à obtenir d’adresse IP. Je ne sais pas comment j’ai fini par penser à désinstaller le client VPN, mais j’ai fini par le faire et ça a restauré ma connexion vers Internet. J’ai redémarré la machine pour que toute trace du client défectueux soit effacée, puis j’ai retenté l’installation. Là, j’avais le client VPN ET l’accès à Internet! J’ai alors pu établir la liaison vers le réseau interne de Nuance! Fiou!

Par contre, il y avait un hic. Chaque recherche web prenait plusieurs secondes tandis qu’elle était instantanée sur ma machine personnelle. Cela affectait TOUT accès vers Internet, incluant le site d’Oracle pour l’API de Java, Google, etc. J’ai déjà eu ce problème par le passé. Il se produisait systématiquement quand je démarrais le client VPN depuis une connexion wi-fi. L’utilisation d’un dongle USB vers Ethernet a résolu le problème, à moins que j’aie bidouillé le profil VPN et ne m’en souvienne plus.

C’est seulement vendredi, 22 novembre, que j’ai trouvé un moyen de résoudre le problème de lenteur excessive de la connexion Internet. Pour cela, il m’a fallu cliquer du bouton droit sur l’icône réseau dans la zone de notification et choisir quelque chose comme Open network and sharing center. De là, j’ai cliqué sur le libellé pour accéder aux options des cartes réseau. Il faut ensuite accéder à la barre de menu, la façon la plus simple étant d’utiliser la combinaison de touches ALT-F. De là, j’ai pu accéder à l’option Advanced settings du menu Advanced.

Il y a là une liste ordonnée des interfaces réseau. Comme l’installation du client VPN a eu lieu après celle du pilote wi-fi et Ethernet, l’adaptateur virtuel de Cisco se trouvait en premier. Il suffisait de le déplacer en fin de liste pour que l’adaptateur réseau Ethernet ait précédence, ce qui redonna la vitesse d’accès à Internet!

Voici de quoi avait l’air ma fenêtre de paramètres avancés après le correctif, qui relève presque du tour de magie!

image001

 

 

La dernière fois, j’avais installé le client VPN après avoir établi une liaison wi-fi si bien que l’interface de Cisco se trouvait en haut de la liste. J’ai branché un adaptateur Ethernet vers USB seulement plus tard, ce qui a installé un nouveau pilote. L’interface réseau USB s’est alors retrouvée en haut de la liste, ce qui a résolu le problème quand j’utilisais l’adaptateur Ethernet vers USB. Là, ma solution est parfaite, fonctionnant en théorie sur wi-fi, mais je n’ai pas encore testé.

Plus d’accès à Outlook

Ensuite, j’ai eu des difficultés avec Outlook 2010. Le logiciel gelait complètement chaque fois que je tentais de répondre à un courrier électronique! Il ne revenait pas à la vie; il fallait le fermer de force puis le redémarrer. Je finis par me rendre compte avec désarroi qu’il gelait aussi quand je tentais d’envoyer un nouveau message! Je n’étais pas complètement bloqué, car au pire, je pouvais utiliser le courriel Web en attendant d’aller au bureau le lundi suivant, mais ça allait moins bien.

Quelques recherches m’ont mené sur la piste d’un potentiel problème de connexion. Comme de fait, Outlook affichait Trying to connect dans le coin inférieur droit. C’était probablement depuis la panne d’Internet causée par le client VPN, car j’avais reçu quelques courriers électroniques après la mise à jour que je n’avais pas encore regardés. J’essayais justement de répondre à l’un d’eux lors du premier gel d’Outlook.

J’ai tenté de réviser les paramètres de connexion et fini par trouver un bouton Repair que j’ai utilisé pour rafistoler la connexion Exchange. Après quelques étapes de vérification, Outlook avait fini la réparation. Je ne me rappelle plus si j’ai dû redémarrer Outlook ou pas, mais un moment donné, il a réussi à se connecter au serveur. La connexion rétablie, je pouvais répondre à mes messages! Fiou!

Ce rétablissement est arrivé à temps, car il y avait un bogue prioritaire de latence à traiter. Ce problème m’a occupé le reste de la journée! J’ai par chance trouvé une solution simple qui va améliorer les choses sans tout casser en contrepartie!

L’anti-virus estropié

Vers la fin de la journée, j’ai découvert que Symantec Endpoint Connection, l’anti-virus utilisé chez Nuance, rapportait souffrir de problèmes. J’ai démarré son interface de contrôle qui m’a proposé de redémarrer les services éteints. Je l’ai fait, ça  a presque fonctionné, mais il y avait du trouble avec le pare-feu. Il semblait falloir réinstaller l’anti-virus! Bon, pas de problème, on va le retrouver sur le site de IT. Je l’ai eu, l’ai téléchargé, puis j’ai tenté l’installation.

Eh bien le programme d’installation se fermait dès le début avec un stupide message d’erreur indiquant qu’il y avait des problèmes de compatibilité. Aucun moyen de savoir quels problèmes il y avait et comment les contourner. Tenter de démarrer en mode de compatibilité Windows 8 et même Windows 7 ne donna aucun résultat, encore. Décidément, le mode de compatibilité est de la frime; ça ne fonctionne pratiquement jamais.  Selon mes recherches sur Google, il fallait installer la version 12.1 RU4 tandis que IT fournit la 11! J’étais donc bloqué.

Lundi, 18 novembre, à moins que ce ne soit mardi, j’ai eu l’idée d’accéder à \\bigiron, un emplacement réseau chez Nuance qui fournit aux employés certains logiciels. J’y ai trouvé une version 12 du Symantec Endpoint Connection. Cette fois, je pouvais démarrer le programme d’installation. J’ai tenté de procéder à une réparation, mais cela n’a absolument rien changé. Il fallait essayer de désinstaller puis réinstaller, mais, encore un autre problème me barra la route: il fallait un mot de passe pour procéder à l’installation.

Refusant de me laisser démonter, rendu chez moi le soir venu, j’ai fouillé un peu sur Internet et trouvé des parades pour contourner le mot de passe! Certains articles proposaient des manipulations dans la base de Registre tandis que d’autres se référaient à un logiciel nommé Cleanwipe, disponible uniquement auprès du support technique de Symantec, et permettant de désinstaller complètement le logiciel. J’ai bien cru qu’il allait me falloir obtenir ce logiciel-là, car aucune des manipulations de base de registre ne fonctionnait. Elles se référaient à des clés inexistantes que j’en vins à tenter de créer, mais j’obtenais des erreurs lorsque j’essayais.

Par chance, je suis tombé sur un article dont le lien ne fonctionne plus aujourd’hui (décidément, il y a une tendance généralisée à tout désactiver et supprimer sur Internet, peut-être tous ces serveurs en PHP et en ASP.NET qui sont trop fragiles). Pour réussir à désinstaller le produit, j’ai double-cliqué sur le bouclier, ce qui a démarré l’interface du logiciel. J’ai cliqué sur Help puis Troubleshoot. De là, j’ai abouti à une zone permettant d’exporter et importer un fichier de politique de sécurité.

J’ai exporté la politique, ce qui a produit un fichier dans le format XML. J’ai altéré ce fichier avec un éditeur de texte pour configurer l’attribut uninstallPassword ou quelque chose du genre sur 0, puis j’ai réimporté la politique modifiée. Ensuite, le programme de désinstallation m’a permis de supprimer l’anti-virus défectueux!

J’ai redémarré la machine pour être bien certain que toute trace soit effacée, puis j’ai procédé à la réinstallation. Cela s’est bien passé et, après ça, le pare-feu fonctionnait correctement!

Est-ce mieux pour Windows Update?

Plus ou moins! J’ai donc effectué tout ça pour pas grand-chose. D’abord, Windows Update est difficile d’accès: taper cela dans l’interface Metro ne donne même pas de référence vers l’application. Il m’a fallu taper updates pour enfin avoir Check for updates et l’application, encore, ne fonctionnait pas. Il me disait de réessayer. J’ai cliquer pour accéder à Windows Update et lui au moins me disait qu’aucune mise à jour n’était disponible, plutôt que cracher une erreur comme sous Windows 8.

Autres problèmes

J’ai encore eu ce filigrane à propos de SecureBoot. Par chance, la petite patch que j’avais trouvée l’autre fois a fonctionné de nouveau, me débarrassant de ce mineur défaut.

3 réponses sur “Une mise à jour vers Windows 8.1 rock’n’roll qui en fait baver!”

  1. Bonjour,
    Après mise à jour de Win 8 vers Win 8.1 suite à la suggestion de Store, j’ai perdu ma connexion internet.
    Mon ordinateur portable Asus N76VM détecte tous les réseaux Wifi mais ne se connecte pas à internet. Il affiche connexion limité.
    Merci de votre aide

      1. Si jamais tu n’as qu’une seule machine qui peut se connecter à Internet, tu devras probablement effectuer une restauration aux paramètres d’origine, ce qui va effacer tes applications et tes données. Tu pourras par la suite, au moins, télécharger le pilote wi-fi et réessayer la mise à jour vers Windows 8.1, ou conserver Windows 8.

Laisser un commentaire